Incorrect count of 'Other Issues' - some domains affected
Incident Report for Helpshift
Resolved
This incident has been resolved.
Posted 2 days ago. May 17, 2019 - 18:56 UTC
Identified
The issue has been identified and fix is being implemented. The ETA for resolution is 19:00 UTC.
Posted 2 days ago. May 17, 2019 - 17:25 UTC
Investigating
The count of 'Other Issues' in the Issue view is displayed incorrectly for a few domains.

We are investingating this and will provide an update shortly.
Posted 2 days ago. May 17, 2019 - 15:49 UTC
This incident affected: Management Portal.