Delivery issues with emails
Incident Report for Helpshift
Resolved
Outbound messages are operational.
Posted Jul 13, 2018 - 14:48 UTC
Update
Inbound emails are getting delivered.
Posted Jul 13, 2018 - 13:53 UTC
Monitoring
Currently incoming and outgoing emails are not getting delivered due to an outage in Mailgun. We are monitoring the issue and will post further updates,
Posted Jul 13, 2018 - 12:14 UTC
This incident affected: Email delivery and Inbound email processing.