Message Delivery Workflow
Incident Report for Helpshift
Resolved
This incident has been resolved.
Posted Nov 17, 2023 - 12:37 UTC
Investigating
Currently, our message delivery workflow is in a degraded state. Messages from agents to end users are experiencing a delay.
Posted Nov 17, 2023 - 12:25 UTC
This incident affected: Management Portal.