Partial Outage with the third party who implemented the CAPTCHA

Incident Report for Helpshift

Resolved

This incident has been resolved.
Posted Jul 08, 2024 - 12:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2024 - 12:51 UTC

Investigating

An issue with a third-party vendor currently impacts our issue filing on the Contact Us page in the Help Center. We are discussing the matter with the third party's technical team.
Posted Jul 08, 2024 - 11:57 UTC