Partial Degradation: Issue Auto-assignment (Delay)

Incident Report for Helpshift

Resolved

This incident has been resolved.
Posted Oct 18, 2025 - 17:56 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 18, 2025 - 17:12 UTC

Investigating

We are experiencing a partial degradation of the Issue Auto-assignment feature causing delays in assigning issues to agents.
Posted Oct 18, 2025 - 16:58 UTC
This incident affected: Auto Assignment.