Dashboard experiencing degraded performance

Incident Report for Helpshift

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 13:07 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 08, 2025 - 13:05 UTC

Investigating

We are currently facing an issue with the Dashboard where the 'Create Issue' button has disappeared.
Posted Jul 08, 2025 - 12:42 UTC
This incident affected: Helpshift Dashboard.