Issue with Outbound Mail Delivery system
Incident Report for Helpshift
Resolved
We're pleased to inform you that the incident affecting the Outbound Mail Delivery system has been successfully resolved. We apologize for any inconvenience this has caused, and we appreciate your patience and understanding during this time. If you encounter any additional issues or have any questions, please do not hesitate to contact our support team (support@helpshift.com). I appreciate your cooperation.
Posted May 27, 2024 - 18:13 UTC
Update
We are continuing to monitor for any further issues.
Posted May 27, 2024 - 16:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 27, 2024 - 15:44 UTC
Identified
We are currently experiencing email delivery issues reported by Mailgun. We will provide updates as soon as they are available.
Posted May 27, 2024 - 15:31 UTC
This incident affected: Email delivery.