Helpshift Service Outage

Incident Report for Helpshift

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:09 UTC

Investigating

We are currently experiencing a service outage caused by an issue with our dependent Cloudflare services. This may impact access to Helpshift features and overall platform availability.
As per the Cloudflare status page (https://www.cloudflarestatus.com/), their services are undergoing updates/maintenance, which may be contributing to the disruption.
Posted Dec 05, 2025 - 09:06 UTC
This incident affected: Cloudflare (Third-Party Dependency).