Partial Degradation – Dashboard Analytics (Team Section)

Incident Report for Helpshift

Resolved

This incident has been resolved.
Posted Feb 17, 2026 - 15:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 17, 2026 - 15:05 UTC

Investigating

We are currently experiencing a partial degradation impacting the Team section of Dashboard Analytics.

The following reports are affected:
1. Team – Trends (Overall)
2. Team – Trends (Workload)
3. Team – Summary by Agents
Posted Feb 17, 2026 - 14:58 UTC
This incident affected: Analytics Dashboard.