Service Degradation – Snowflake Outage

Incident Report for Helpshift

Resolved

The issue caused by the Snowflake outage has been resolved. The following services are now fully operational:

Dashboard Analytics
Power BI
Analytics API

Data retrieval and processing have returned to normal, and all affected services are functioning as expected.

If you encounter any related issues, please feel free to reach out to our Support team at support@helpshift.com.

We apologize for any inconvenience caused and appreciate your patience and understanding.
Posted Aug 31, 2026 - 20:57 UTC

Update

We continue to monitor the situation closely and will provide further updates as the issue progresses.
Posted Aug 31, 2026 - 19:15 UTC

Investigating

We are aware of an ongoing Snowflake service outage that is impacting services dependent on Snowflake for data retrieval and processing.

Customer Impact:
Affected services may experience degraded availability, delayed data, or functionality issues.

Status:
We are actively monitoring Snowflake's recovery and assessing the impact on our services. No action is required from customers at this time.

We will continue to provide updates as the situation progresses and will confirm once affected services have returned to normal.
Posted Aug 31, 2026 - 18:02 UTC
This incident affected: Analytics Dashboard, PowerBi, Snowflake (Third-Party Dependency), and Analytics API.