Login into Helpshift with Google account is not working
Incident Report for Helpshift
Resolved
This incident has been resolved. We are continuing to monitor services.
Posted 10 months ago. Sep 27, 2018 - 10:01 UTC
Investigating
Login into Helpshift with Google is not working from 2:50 AM UTC 26 Sept 2018. You can still login with email and password. All other systems are operational. We are currently investing in the issue.
Posted 10 months ago. Sep 27, 2018 - 05:30 UTC
This incident affected: Management Portal.