Service Disruption

Incident Report for Helpshift

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 13:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2026 - 13:06 UTC

Investigating

We are currently experiencing a disruption in service. Our team is actively investigating the issue and working to restore normal functionality as quickly as possible.
Posted Apr 14, 2026 - 12:47 UTC
This incident affected: Helpshift Dashboard.