Degraded performance in outgoing emails from Helpshift
Incident Report for Helpshift
Resolved
This incident is resolved.
Posted 4 months ago. May 10, 2019 - 13:31 UTC
Update
We are continuing to work on the issue - this is taking longer than expected.

The ETA for resolution is 14:00 UTC.
Posted 4 months ago. May 10, 2019 - 12:43 UTC
Identified
We are experiencing a lag in delivery of all outgoing emails (For example, Replies to email issues and new agent invite emails). The problem has been identified and the delayed emails will be delivered in the next 60 minutes.
Posted 4 months ago. May 10, 2019 - 11:51 UTC
This incident affected: Email delivery.