Partial Degradation: Analytics

Incident Report for Helpshift

Resolved

The issue has been resolved. Power BI and Analytics API are now operational.
Posted Oct 21, 2025 - 07:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 07:05 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 21, 2025 - 07:04 UTC

Update

We are awaiting service recovery from our third-party cloud vendor. Power BI and Issues Analytics API remain impacted. We appreciate your patience and will provide updates as soon as the services are restored.
Posted Oct 21, 2025 - 04:38 UTC

Update

Power BI and Issues Analytics API remain impacted. Our team is actively working to resolve the issue at the earliest. We sincerely appreciate your patience and understanding, and we will continue to keep you updated.
Posted Oct 21, 2025 - 03:38 UTC

Update

We're pleased to inform you that Dashboard Analytics is working as expected. However, Power BI and the Issues Analytics API are still impacted.
Our team is actively working to resolve the issue at the earliest. We sincerely appreciate your patience and understanding, and we will continue to keep you updated.
Posted Oct 20, 2025 - 23:50 UTC

Investigating

We are currently experiencing a Partial Outage impacting the following components:
- Analytics API
- PowerBI services
- Dashboard Analytics

This is due to the Ongoing AWS Outage: https://health.aws.amazon.com/health/status

Our team is actively investigating and working to restore full functionality.
Posted Oct 20, 2025 - 13:22 UTC
This incident affected: Analytics Dashboard, Issues Analytics API, PowerBi, and AI Agent Copilot Analytics.