Auto Assignments are not working
Incident Report for Helpshift
Resolved
The issue has been resolved.
Posted Oct 09, 2019 - 18:12 UTC
Update
We are continuing to investigate this issue.
Posted Oct 09, 2019 - 16:14 UTC
Investigating
We are currently investigating this issue.
Posted Oct 09, 2019 - 15:04 UTC