Degraded performance in auto-assignment.

Incident Report for Helpshift

Resolved

We’re happy to share that the issue has now been successfully resolved. We sincerely apologize for any inconvenience this may have caused. Thank you again for your continued patience and support during this time.
Posted Jul 15, 2025 - 17:29 UTC

Update

We appreciate your patience while we continue to investigate this matter.
Posted Jul 13, 2025 - 11:42 UTC

Update

Our investigation into this matter is ongoing, and we remain fully committed to resolving it promptly.
Posted Jul 12, 2025 - 18:19 UTC

Investigating

We’re currently facing an issue with the Auto Assignment feature, where users are being assigned more tickets than the set limit. Our team is actively investigating this with top priority and working toward a quick resolution. We will keep you informed on the progress.
Posted Jul 12, 2025 - 15:44 UTC
This incident affected: Auto Assignment.