Intermittent Issue with Dashboard
Incident Report for Helpshift
Resolved
Dashboard is now operational.
Posted 4 months ago. Jan 23, 2019 - 06:20 UTC
Investigating
We are currently having an intermittent issue with the Agent Dashboard. We are looking into it and will have an update in next 30 minutes.
Posted 4 months ago. Jan 23, 2019 - 05:58 UTC
This incident affected: Management Portal.