Degraded performance on Helpshift Campaigns Analytics
Incident Report for Helpshift
Resolved
Campaigns reporting is working as expected.
Posted 3 months ago. Jun 19, 2019 - 11:57 UTC
Investigating
Reporting for Helpshift Campaigns Analytics is currently not displaying stats. We are currently investigating the issue
Posted 3 months ago. Jun 19, 2019 - 10:12 UTC
This incident affected: Campaigns.