System Update - Auto Assignment

Scheduled for Feb 16, 05:30 - 09:30 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Feb 12, 2026 - 10:51 UTC

Update

We will be conducting a system update from February 13, 2026, 05:30 AM UTC to February 16, 2026, 09:30 AM UTC.

During this period, the below functionality will see some degree of latency:
Auto Assignment
Posted Feb 12, 2026 - 10:43 UTC

Scheduled

We will be conducting a system update from February 13, 2026, 05:30 AM UTC to February 13, 2026, 09:30 AM UTC.

During this period, the below functionality will see some degree of latency:
Auto Assignment
Posted Feb 11, 2026 - 17:16 UTC
This scheduled maintenance affects: Auto Assignment.